0

Discussion topic: **Sky Mobile SIM card not receiving signal after returning from Albania**

Reply
This message was authored by Skycustomer9999 This message was authored by: Skycustomer9999

**Sky Mobile SIM card not receiving signal after returning from Albania**

**Sky Mobile SIM card not receiving signal after returning from Albania** 

Im hoping someone or SKY can help me here. I visited Albania for 7 days, and bought a Vodaphone Simcard out there to use. Used the vodaphone SIM card and no problem using it on my Iphone15promax. Returned back to the UK, inserted my Sky SIM card and now I'm no longer getting any signal- I insert my SIM card, it indicates that it's searching for a signal but then fails to retrieve one. I can't call, text, receive calls or even receive voicemails- 'call fails'. I know for sure I did not have to alter anything on my mobile network settings. I've done the standard trouble shooting such as, restarting phone, resetting network settings, took out SIM card and cleaned it, updated to the new IOS software but still no positive outcome. I don't know if this helps but I've reached my spend cap of £50 and even increased the limit to £100( just to see if this might help) FYI also ran through the device troubleshooting that sky offers but still not helpful.

 

Please help someone!!!  

Reply

All Replies

This message was authored by Daniel0210 This message was authored by: Daniel0210

Re: **Sky Mobile SIM card not receiving signal after returning from Albania**

Posted by a Superuser, not a Sky employee. Find out more

@Skycustomer9999 

You mention iOS so presumably you have an iPhone. Have you tried this?

Settings > Mobile Data > SIM Applications > Make sure this is set to Home.

 


▪️I AM NOT A SKY EMPLOYEE ▪️
Sky customer since 2001
with: Sky Q | Sky Superfast Broadband | Sky Talk | Sky Mobile
NOTE: I only provide help on the forums and NOT via PM
Skycustomer9999
Topic Author
This message was authored by Skycustomer9999 This message was authored by: Skycustomer9999

Re: **Sky Mobile SIM card not receiving signal after returning from Albania**

Hi there @Daniel0210 cheers for replying. Yes ive tried this, tried it again just to be sure. When i follow that and set to home it indicates that its already active.

 

aaaaaah!

Reply

Was this discussion not helpful?

No problem. Browse or search to find help, or start a new discussion on Community.

Start a new discussion

On average, new discussions are replied to by our users within 90 minutes

New Discussion