18

Discussion topic: Sky Go not working on new M2 Mac

Reply
Reply
This message was authored by alcilan This message was authored by: alcilan

Re: Sky Go not working on new M2 Mac

@OwainGlyndwr You are an absolute star! Thank you so much! (or should I say, diolch yn fawr iawn, given your username?). 

I'm happily typing this on my M1 MacBook Air in my caravan in the Berwyn mountains, North Wales. I only need Sky Go when here and I knew it worked when I was last here in 2023! 

I followed your instructions and it works fine. It's not the easiest thing to do and I appreciate some may struggle with this method. Sky are letting their customers down with this. Surely a better way would be for them to include an uninstaller in their installler app, so a clean install is done, rather than people having to do it manually? 

I'm no longer stuck on that first blue screen with a 'play' logo! Thanks again! 

 

This message was authored by designerlondon This message was authored by: designerlondon

Re: Sky Go not working on new M2 Mac

Hopefully they'll have higher quality video on there soon, else will just go and buy yet another iPad 

---------------------------------------
Sky Q since Feb 2018, 2TB Box (Community Fibre 1GBbps), Sky Full Package, UHD, 2 x Multiscreen, VIP, MacBook Pro M2 Max 16” / 96GB / 2TB SSD / Ventura 13.6.1, iMac 27” 4 GHz Quad-Core i7 / 32GB / 2TB fusion / 4GB AMD Radeon R9 M239X, Monterey 12.7, iPhone 13 Pro / 256GB / iOS 16,6.1, iPad Air 2, 1080p TVs only
This message was authored by ABoM This message was authored by: ABoM

Re: Sky Go not working on new M2 Mac

@OwainGlyndwr - thanks very much - followed your instrutions and it now works perfectly.

 

This message was authored by Jenny+wwh This message was authored by: Jenny+wwh

Re: Sky Go not working on new M2 Mac

I followed the process and finally got Sky Go to work on a New M2 Mac. I used to have Sky Go working on previous Mac Mini last year.

 

Reasons it may not have worked before :  I moved machines from a Mac Mini to a Mac studio using Time machine which would have carried over all the configuration and plist files that may have included device IDs etc.   

 

Removing all the previous  files and directories forcing a fresh install seem to be the key here.

 

Extra Details :

I had a look in the locations listed to see which had old files..... using this terminal line command 

 

 % for i in   ~/Library/Preferences/  ~/Library/Application\ Support  ~/Library/Caches/  ~/Library/Logs/  ~/Library/LaunchAgents  ~/Library/Cookies ~/Library/Group\ Containers

do

echo # $i

ls -l $i | grep -i sky | grep -iv skype

done

Giving .....

# /Users/clive/Library/Preferences/

-rw-------   1 fred  staff      75 10 Juxn  2023 com.bskyb.skygoplayer.helper.plist

-rw-------   1 fred  staff     264 15 Juxn 09:28 com.bskyb.skygoplayer.plist

# /Users/fred/Library/Application Support

drwx------  68 fred  staff  2176 15 Juxn 10:20 Sky Go

drwx------   3 fred  staff    96 15 Juxn 10:09 com.bskyb.skygoplayer

# /Users/fred/Library/Caches/

drwxr-xr-x   6 fred  staff      192 15 Juxn 10:08 com.bskyb.installer.go

# /Users/fred/Library/Logs/

drwx------   2 fred  staff                 64 15 Juxn 09:27 Sky Go

# /Users/fred/Library/LaunchAgents

# /Users/fred/Library/Cookies

# /Users/fred/Library/Group Containers

 

Moving the Directories and files located to the trash then reinstalling the downloaded SkyGoinstaller  did thre trick. After Authenticating the  App worked as expected. I did not see the expected "connect to local devices" dialog box  but the app can see the Sky Q box on the local network.

 

Text above  mangled a bit EG  to Juxn from Jun becuase the posting services moaned.
 

 

 

 

Reply

Was this discussion not helpful?

No problem. Browse or search to find help, or start a new discussion on Community.

Start a new discussion

On average, new discussions are replied to by our users within 3.6 hours

New Discussion