Discussion topic: Technical issue

This message was authored by Gilbz This message was authored by: Gilbz

Technical issue

sky comes on to the normal Home Screen, but the remote won't let me scroll up or down or press anything. I tried changing the batteries and recalibrating the controller but neither did anything and after a brief time sky goes off and it just says no input 


All Replies

This message was authored by MarkGoldsmith This message was authored by: MarkGoldsmith

Re: Technical issue

Posted by a Superuser, not a Sky employee. Find out more

Some things to try


reset the remote

Press 7 and 9 together on your Sky remote for three seconds (This resets/clears the remote)
Press 1 and 3 together for three seconds (bluetooth mode) and follow any on-screen instructions.

The next option sounds insane but a number of users have reported it resolving the issue with their remotes. You could try holding the remote at both ends and giving it a gentle twist as though you were wringing out a towel. 

The last option to try and fix the remote is to remove the batteries for several hours and then put them back in before trying a reset of the remote.

If none of these options work you can request a replacement remote via this link: https://www.sky.com/help/forms/streaming-tv-remote

If you have an old Sky Q remote, you can use that as an interim solution whilst you await the new remote.

Sky Stream user. Former Sky+ HD and Sky Broadband customer
Please LIKE any responses you found helpful
Please mark a response as an ANSWER if it has solved your query/issue

NOT a Sky Employee


Was this discussion not helpful?

No problem. Browse or search to find help, or start a new discussion on Community.

Start a new discussion

New Discussion