Discussion topic: WPS amber on booster, Sky Q and router

This message was authored by Coutts75 This message was authored by: Coutts75

WPS amber on booster, Sky Q and router

Sky booster suddenly not working so can't watch TV/get signal around house.

Have reset and relocated the booster nearer to the router, but it's still not connecting when pressing WPS.

Have reset router several times too, but they aren't talking. 

Unable to get Sky Q to connect so affecting TV too.

Have unplugged everything and started from scratch.

Router lights are all on and green except WPS light.

Booster power and wifi lights are green but not connected light or WPS.

Nothing has changed so unsure why happening all of a sudden. Any tips please as SKY not answering after 9pm



All Replies

This message was authored by Dallen9798 This message was authored by: Dallen9798

Re: WPS amber on booster, Sky Q and router

Try turning off the Q box at the mains


Reset your hub & booster by holding the reset button down for 30 seconds.


Allow the Hub to obtain its 3 green lights and then the booster to get the 2 green lights


Press & hold the WPS button on the booster for 3-5 seconds and then repeat the process on the hub.



If it doesn't connect try connect your Q box to your hub through the password rather than the WPS button by clicking the option on the TV that says "Connect to broadband from another providor"


If it still doesn't connect it may be best giving Sky a call as it may be an equipment issue.

My views are my own and I will assist where possible.

Sky Q 2TB UHD, 2X Mini Box, Sky BB UF1, Booster 4

I am just a customer, If I've got something wrong feel free to tell me, If I've something right mark it as an answer

Was this discussion not helpful?

No problem. Browse or search to find help, or start a new discussion on Community.

Start a new discussion

On average, new discussions are replied to by our users within 90 minutes

New Discussion