Discussion topic: Hi, I seem to have lost access to our Broadband Shield.

This message was authored by BarringtonAyre This message was authored by: BarringtonAyre

Hi, I seem to have lost access to our Broadband Shield.

Hi, I seem to have lost access and any control to our Broadband Shield.

When I try and access it on the app it simply says either just number 1. Choose what you want and then nothing else or as per the picture below it gives me options 1.  And 2. But I can't actually access anything else.


 I called the help desk and when we tried to log on using a different browser it did the same thing.


We then tried to access everything online using my laptop and when I got to the broadband shield part the broadband shield was greyed out and it said to check back when my broadband was active even though it is active.


I have young children at home so this is one of the reasons we chose Sky Broadband and so if I can't access the shield I will need to change provider.


The very helpful chap on the phone did deactivate and then reactivate the shield but still nothing worked


He then suggested I try here


looking forward to any help out there please


Thank you


Was this discussion not helpful?

No problem. Browse or search to find help, or start a new discussion on Community.

Start a new discussion

On average, new discussions are replied to by our users within 4 hours

New Discussion