Constant amber internet light

Community Manager

Solid amber light.jpg


A constant amber internet light on your Sky Hub suggests your Hub can detect a broadband connection but can’t connect to it.


What could be causing this?


Recently joined Sky? 

If you've recently joined Sky Broadband and your services haven’t been activated yet, your Sky Hub may show a solid amber light.


Telephone exchange issue 

From time-to-time, maintenance work will be required at your local phone exchange. To minimise disruption, this work tends to take place during the night. Sky’s service status page will keep you up to date with work taking place at your local phone exchange.


Constant amber light? Follow these steps on


How is your Hub set up?

Setups can vary from home to home, but generally, your Sky Hub should be connected to your master phone socket. This link will allow you to test your phone line and troubleshoot this issue.


Sky Broadband setup .pngMaster Socket > Microfilter > ADSL cable > Sky Hub

For further support, ask the Sky Broadband community.

About the author

I joined Sky in 2011 and haven't looked back since! I am passionate about helping others and all things Sport. My favourite TV show changes all the time, but I bought The West Wing Box Set from Sky Store, which I regularly re-watch.

I'm having this problem since Wednesday and still no internet, not getting help just been told wait a few hrs and see if it comes back..its now Friday evening still no internet r sign of that getting fixed..🤔🙁

New Viewer

I have same problem each year! For that prise wich we all paying for sky We shouldn't have any problems at all!


Soliid amber light on the Sky Hub. No broadband. Land line okay. Did all the diagnostics and eventually had a message saying problem outside my prooerty. Engineer booked...will resolved by 26th January! Ouch. I work from home....!

New Viewer

Sky hub not working just has a constant orange light for the internet symbol, tried turning it on and off tried resetting it. nothing seems to be working was working fine this morning.