0

Discussion topic: Ethernet ports not working on Sky Router

Reply
This message was authored by TZun This message was authored by: TZun

Ethernet ports not working on Sky Router

I am new to Sky and I have a new Sky router, wifi is working just fine but when I use the ethernet ports on the router they do not seem to  be working. I have tried multiple devices including my laptop and these all do not work when plugged in directly to the router. This is proving difficult becasue I have a few devices that do hot have wifi to be connected to the internet.

 

I have reset the router and all the devices with no effect.

 

Thanks in advance.

 

 

Reply

All Replies

This message was authored by JPR007 This message was authored by: JPR007

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@TZun When you say doesn't work, do you mean there is no connection registered on the devices, or is it that it's connected but there's a network problem? It's very rare to have issues with cabled connections, they either work or don't.

Are the lights flashing on the back of the router on the Ethernet connections or is there nothing? Have you checked the cables aren't damaged?

----------------------------------------------------------------------------------------------------------------------------------------------
Zen Superfast (FTTC), Fritzbox 7530, Sky Q 2TB UHD v3 (x1), Sky Q Mini (x2), Alienware Area 51-M, Panasonic TX-65HZ1000B, Denon AVR-X6300H, B&W CM8 S2, B&W CM1 S2 (x2), B&W CM Centre S2, REL S3 SHO (x2), Panasonic TX-P42G30B, Monitor Audio RS6, Marantz PM7001 KI, Denon HEOS 1 HS2 (x2), B&W P7, iPad Pro 12.9" (5th Gen), iPhone 14 Pro Max, iPad Mini 6 (work)

** No - I have nothing to do with Sky **
TZun
Topic Author
This message was authored by TZun This message was authored by: TZun

Re: Ethernet ports not working on Sky Router

@JPR007 Thank you for your assistance, I was getting a no connection prompt from the pc and browser. The lights on the port to where both light up to signify link and data, I also used multiple cables with a tester to confirm they were working. A little bit more about my setup. I have a powerline adaptor (TP Link Av600) going to my attic to from my main Sky Router to a switch (TP Link LS1005G) and another wifi router (TP link WR841N.) for home IOT devices. This was setup on my previous router without issue, (FritzBox 7530).

 

Thanks for you help!

This message was authored by jamesn123 This message was authored by: jamesn123

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@TZun 

Have you tried direct to the router? It may be the powerline adapters causing the problem?

I am NOT a Sky Employee
Myself & Others offer our time to help others, please be respectful.
This message was authored by DougieS This message was authored by: DougieS

Re: Ethernet ports not working on Sky Router

I'm having the exact same problem. Joined Sky broadband this morning. No ethernet connection to any devices using any cable. Come on Sky, sort this out please.

This message was authored by Chrisee This message was authored by: Chrisee

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@DougieS if you have folowed the steps suggested in the thread above it maybe you have a dodgy hub in which case call Sky to get it changed. Odd samples of any product can have faults.

=========================================================
65inch Sky Glass, 3 Sky Streaming Pucks, Sky Ultrafast + and Sky SR213(white Wifi Max hub) main Wifi from 3 TP-Link Deco M4 units in access point mode
This message was authored by DougieS This message was authored by: DougieS

Re: Ethernet ports not working on Sky Router

Thanks very much for the prompt reply. Had BT up to last evening, on the same cables etc and everything was fine. I'll contact sky as you suggest.

This message was authored by Michael63849588 This message was authored by: Michael63849588

Re: Ethernet ports not working on Sky Router

Did you ever get to the bottom of this? I am having the same issue 

This message was authored by Chrisee This message was authored by: Chrisee

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@Michael63849588 you would be better explaining what your issue is and how your network is set up. Direct ethernet connections normally work where they dont most likely issue is a dodgy cable

=========================================================
65inch Sky Glass, 3 Sky Streaming Pucks, Sky Ultrafast + and Sky SR213(white Wifi Max hub) main Wifi from 3 TP-Link Deco M4 units in access point mode
This message was authored by Michael63849588 This message was authored by: Michael63849588

Re: Ethernet ports not working on Sky Router

Thanks for the reply 

I was with BT before, the Ethernet cable went to my CCTV cameras upstairs 

Ever since I have switched to sky, the cameras are offline and say no internet connection

This message was authored by jamesn123 This message was authored by: jamesn123

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@Michael63849588 

This is usually because CCTV systems have a static IP set in them. When you change ISPs the local IP address space usually changes. For example BT uses the 192.168.1.XXX address space whereas Sky uses the 192.168.0.XXX space. You either need to change the static IP of your CCTV system to one within the Sky hubs IP range or change it to use DHCP and let the Sky hub give it an IP. 

I am NOT a Sky Employee
Myself & Others offer our time to help others, please be respectful.
This message was authored by Michael63849588 This message was authored by: Michael63849588

Re: Ethernet ports not working on Sky Router

Thanks for the reply

I  have tried this also but still won't connect unfortunately.

This message was authored by jamesn123 This message was authored by: jamesn123

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@Michael63849588 

Only other thing I can think of is that the ethernet cable you are using to connect the Sky hub to your CCTV system is a cheaper 2 pair cable which the Sky hub doesn't always play nicely with. I'd recommend getting a new ethernet cable that you know is rated for 1gbps/has all 4 pairs wired. 

I am NOT a Sky Employee
Myself & Others offer our time to help others, please be respectful.
This message was authored by Lynette50 This message was authored by: Lynette50

Re: Ethernet ports not working on Sky Router

I have the same issue. Ethernet all fine then upgraded to Fibre and new router and now Wifi great but no ethernet cable working.  Does Ethernet work with fibre? as it was perfect before and now as soon as new router know its not a cable issue. 

This message was authored by jamesn123 This message was authored by: jamesn123

Re: Ethernet ports not working on Sky Router

Posted by a Superuser, not a Sky employee. Find out more

@Lynette50 

How do you know it isnt the cable? Have you tried a different one?

If you had read my reply you'd know that newer Sky hubs need all 4 pairs wired up in the ethernet cable compared to older Sky hubs which were okay with just 2 pairs. 

I am NOT a Sky Employee
Myself & Others offer our time to help others, please be respectful.
Reply

Was this discussion not helpful?

No problem. Browse or search to find help, or start a new discussion on Community.

Start a new discussion

On average, new discussions are replied to by our users within 4 hours

New Discussion