Archived Discussions
This page has been archived
The content on this page may be out-of-date or have been superseded by newer information. Links on this page to other sites may not work and contact information may be inaccurate. This page has been archived for future reference. Learn more about this message
Reply
I'm New Here
CJ+Fordska
Posts: 1
Joined: ‎09-06-2011
Accepted Solution

Lost signal

My sky programmes keep freezing and a message comes up 'technical fault - switch off your box for 5 minutes'. I phoned up asking for Sky to fix this and they said they would have to charge me £60 because my box was out of warranty. Does anyone else think that this is a bloody liberty especially as I pay them £50 a month as it is. I now have to pay them to fix their own box so I can carry on paying them money each month? No thanks!!! Virgin here I come!

Please do not post any personal details or account information. Please use plain text.
Staff
Robert
Posts: 7,723
Joined: ‎08-12-2010

Re: Lost signal

Hi CJ+Fordska, 

 

I'm sorry you feel this way, the Sky equipment provided to you is covered by a 12 month manufacturers warranty from the date of installation after which it becomes your responsibility to maintain.


In the event you experience any issues with your equipment and it is out of warranty you still have the option of taking extended warranty to cover the existing fault and protect the equipment for 12 months. Please see the Sky Protect website for more details.

 

Please use the Contact Us page to discuss the options available with our Customer Help team.

Please do not post any personal details or account information. Please use plain text.
Getting There
snouter
Posts: 1
Joined: ‎25-05-2011

Re: Lost signal

i have had exactly the same trouble and they told me exactly the same, there quick enough take the money every month but when it comes to sortin out problems or faults they dont care less, there waste of time and im seriously considering cancelling mine 2

Please do not post any personal details or account information. Please use plain text.
Staff
michael-r
Posts: 1,154
Joined: ‎22-12-2010

Re: Lost signal

[ Edited ]

Hi snouter,

 

Welcome to the forum, sorry to hear you are having issues.

 

Are you able to confirm which installed products you are having an issue with?

Please do not post any personal details or account information. Please use plain text.